MP for Veeam Backup and Replication Reference

MP for Veeam Backup & Replication Reference

 Top Next

Online reference provides basic assistance information for Management Pack for Veeam Backup & Replication objects and properties, discoveries, rules, monitors and metric definitions.

Objects and Properties

Discoveries

Rules and Monitors

MP for Veeam Backup & Replication Metric Definitions


Objects and Properties

 Top Previous Next

This section describes MP for Veeam Backup & Replication objects and properties.

Veeam Backup Library

Veeam Backup Base Discovery


Veeam Backup Library

Display Name | Object ID | Properties
 |  | Display Name | Key
Veeam Backup Abstract Job | Veeam.Backup.AbstractBackupJob | Backup Server |
 |  | InstanceUid | ✓
 |  | Platform |
 |  | Schedule |
 |  | Schedule Enabled |
 |  | Type |
 |  | Display Name |
Veeam Backup Copy Job | Veeam.Backup.CopyJob | Restore points to keep |
 |  | Source WAN Accelerator |
 |  | Target Repository |
 |  | Target WAN Accelerator |
 |  | WAN Acceleration |
 |  | Display Name |
Veeam Backup Enterprise Manager Group | Veeam.Backup.EnterpriseManager.Group | Display Name |
Veeam Backup Job | Veeam.Backup.BackupJob | Restore points to keep |
 |  | Target Repository |
 |  | Display Name |
Veeam Backup Job Group | Veeam.Backup.Job.Group | Display Name |
Veeam Backup Jobs | Veeam.Backup.Job.Container | Backup Server |
 |  | Display Name |
Veeam Backup Proxies | Veeam.Backup.BackupProxy.Container | Backup Server |
 |  | Display Name |
Veeam Backup Proxy | Veeam.Backup.BackupProxy | Connected Datastores |
 |  | Disabled |
 |  | Host |
 |  | InstanceUid | ✓
 |  | Max Concurrent Tasks |
 |  | Transport Mode |
 |  | Type |
 |  | Version |
 |  | Display Name |
Veeam Backup Proxy Group | Veeam.Backup.BackupProxy.Group | Display Name |
Veeam Backup Repositories | Veeam.Backup.BackupRepository.Container | Backup Server |
 |  | Display Name |
Veeam Backup Repository | Veeam.Backup.BackupRepository | Capacity GB |
 |  | Host |
 |  | InstanceUid | ✓
 |  | Max Concurrent Jobs |
 |  | Path |
 |  | Type |
 |  | Version |
 |  | vPower Enabled |
 |  | vPower Path |
 |  | Display Name |
Veeam Backup Repository Group | Veeam.Backup.BackupRepository.Group | Display Name |
Veeam Backup Server Group | Veeam.Backup.BackupServer.Group | Display Name |
Veeam Backup to Tape Job | Veeam.Backup.VmTapeBackupJob | Full Backup Media Pool |
 |  | Incremental Backup Media Pool |
 |  | Display Name |
Veeam File to Tape Job | Veeam.Backup.FileTapeBackupJob | Full Backup Media Pool |
 |  | Incremental Backup Media Pool |
 |  | Display Name |
Veeam Replication Job | Veeam.Backup.ReplicaJob | Replica Location |
 |  | Restore points to keep |
 |  | Target Repository |
 |  | Display Name |
Veeam SureBackup Job | Veeam.Backup.SureBackupJob | Application group |
 |  | Linked Jobs |
 |  | Display Name |
Veeam VM/File Copy Job | Veeam.Backup.FileCopyJob | Display Name |
Veeam WAN Accelerator | Veeam.Backup.WANAccelerator | Cache Path |
 |  | Configured Cache Size GB |
 |  | Connection Count |
 |  | Host |
 |  | Host Type |
 |  | InstanceUid | ✓
 |  | Traffic Port |
 |  | Version |
 |  | Display Name |
Veeam WAN Accelerator Group | Veeam.Backup.WANAccelerator.Group | Display Name |
Veeam WAN Accelerators | Veeam.Backup.WANAccelerator.Container | Backup Server |
 |  | Display Name |


Veeam Backup Base Discovery

Display Name | Object ID | Properties
 |  | Display Name | Key
Veeam Backup Catalog Data Service | Veeam.Backup.CatalogService | Display Name |
Veeam Backup Computers Group | Veeam.Backup.Computers.Group | Display Name |
Veeam Backup Enterprise Manager | Veeam.Backup.EnterpriseManager | URL |
 |  | Version |
 |  | Display Name |
Veeam Backup Hyper-V Integration Service | Veeam.Backup.HVIntegrationService | Display Name |
Veeam Backup Proxy Service | Veeam.Backup.ProxyService | Display Name |
Veeam Backup Server | Veeam.Backup.BackupServer | Proxy Servers |
 |  | Repositories |
 |  | Version |
 |  | Display Name |
Veeam Installer Service | Veeam.Backup.InstallerService | Display Name |
Veeam vPower NFS Service | Veeam.Backup.NFSService | Display Name |
Veeam WAN Accelerator Service | Veeam.Backup.WANService | Cache Path |
 |  | Cache Size Max GB |
 |  | Connection Count |
 |  | Host |
 |  | Host Type |
 |  | Traffic Port |
 |  | Display Name |


Discoveries

This section describes MP for Veeam Backup & Replication discoveries.

Veeam Backup Base Discovery

Veeam Backup Discovery


Veeam Backup Base Discovery

Display Name | Discovery ID | Properties
 |  | Object Name | Property ID | Display Name
Veeam Backup Catalog Data Service Discovery | Veeam.Backup.CatalogService.Discovery | Veeam Backup Catalog Data Service | DisplayName |
Veeam Backup Enterprise Manager Discovery | Veeam.Backup.EnterpriseManager.Discovery | Veeam Backup Enterprise Manager | DisplayName |
Veeam Backup Enterprise Manager Server Properties Discovery | Veeam.Backup.EnterpriseManagerProperties.Discovery | Veeam Backup Enterprise Manager | Version | Version
 |  |  | URL | URL
Veeam Backup Hyper-V Integration Service Discovery | Veeam.Backup.HVIntegrationService.Discovery | Veeam Backup Hyper-V Integration Service | DisplayName |
Veeam Backup Installer Service Discovery | Veeam.Backup.InstallerService.Discovery | Veeam Installer Service | DisplayName |
Veeam Backup Proxy Service Discovery | Veeam.Backup.ProxyService.Discovery | Veeam Backup Proxy Service | DisplayName |
Veeam Backup Server Discovery | Veeam.Backup.BackupServer.Discovery | Veeam Backup Server | DisplayName |
Veeam Backup vPower NFS Service Discovery | Veeam.Backup.NFSService.Discovery | Veeam vPower NFS Service | DisplayName |
Veeam Backup WAN Accelerator Service Discovery | Veeam.Backup.WANService.Discovery | Veeam WAN Accelerator Service | DisplayName |
 |  |  | Port | Traffic Port
 |  |  | ConnectionCount | Connection Count
 |  |  | CachePath | Cache Path
 |  |  | CacheMaxSize | Cache Size Max GB
 |  |  | HostType | Host Type


Veeam Backup Discovery

Display Name | Discovery ID | Properties
 |  | Object Name | Property ID | Display Name
Veeam Backup Core Topology Discovery | Veeam.Backup.CoreTopology.Discovery | Veeam WAN Accelerators | DisplayName |
 |  |  | PrincipalName |
 |  |  | BackupServer | Backup Server
 |  | Veeam WAN Accelerator | DisplayName |
 |  |  | PrincipalName |
 |  |  | InstanceUid | InstanceUid
 |  |  | Version | Version
 |  |  | Port | Traffic Port
 |  |  | ConnectionCount | Connection Count
 |  |  | CachePath | Cache Path
 |  |  | CacheMaxSize | Configured Cache Size GB
 |  |  | Host | Host
 |  |  | HostType | Host Type
 |  | Veeam Backup Proxies | DisplayName |
 |  |  | PrincipalName |
 |  |  | BackupServer | Backup Server
 |  | Veeam Backup Proxy | DisplayName |
 |  |  | PrincipalName |
 |  |  | InstanceUid | InstanceUid
 |  |  | Version | Version
 |  |  | Type | Type
 |  |  | MaxConcurTasks | Max Concurrent Tasks
 |  |  | TransportMode | Transport Mode
 |  |  | DatastoreDetection | Connected Datastores
 |  |  | Disabled | Disabled
 |  |  | Host | Host
 |  | Veeam Backup Jobs | DisplayName |
 |  |  | PrincipalName |
 |  |  | BackupServer | Backup Server
Veeam Backup Enterprise Manager contains Veeam Backup Server relationship Discovery | Veeam.Backup.EnterpriseManagerContainsBackupServer.Discovery |
Veeam Backup Job Discovery | Veeam.Backup.BackupJob.Discovery | Veeam Backup Abstract Job | DisplayName |
 |  |  | PrincipalName |
 |  |  | InstanceUid | InstanceUid
 |  |  | Type | Type
 |  |  | BackupServer | Backup Server
 |  |  | Schedule | Schedule
 |  |  | ScheduleEnabled | Schedule Enabled
 |  | Veeam Backup Job | DisplayName |
 |  |  | PrincipalName |
 |  |  | InstanceUid |
 |  |  | Type |
 |  |  | BackupServer |
 |  |  | Schedule |
 |  |  | ScheduleEnabled |
 |  |  | Repository | Target Repository
 |  |  | Retention | Restore points to keep
 |  | Veeam Replication Job | DisplayName |
 |  |  | PrincipalName |
 |  |  | InstanceUid |
 |  |  | Type |
 |  |  | BackupServer |
 |  |  | Schedule |
 |  |  | ScheduleEnabled |
 |  |  | Repository | Target Repository
 |  |  | Retention | Restore points to keep
 |  |  | ReplicaLocation | Replica Location
 |  | Veeam Backup Copy Job | DisplayName |
 |  |  | PrincipalName |
 |  |  | InstanceUid |
 |  |  | Type |
 |  |  | BackupServer |
 |  |  | Schedule |
 |  |  | ScheduleEnabled |
 |  |  | Repository | Target Repository
 |  |  | SourceWAN | Source WAN Accelerator
 |  |  | TargetWAN | Target WAN Accelerator
 |  |  | Retention | Restore points to keep
 |  |  | UsesWANs | WAN Acceleration
 |  | Veeam VM/File Copy Job | DisplayName |
 |  |  | PrincipalName |
 |  |  | InstanceUid |
 |  |  | Type |
 |  |  | BackupServer |
 |  |  | Schedule |
 |  |  | ScheduleEnabled |
 |  | Veeam File to Tape Job | DisplayName |
 |  |  | PrincipalName |
 |  |  | InstanceUid |
 |  |  | Type |
 |  |  | BackupServer |
 |  |  | Schedule |
 |  |  | ScheduleEnabled |
 |  |  | FullMediaPool | Full Backup Media Pool
 |  |  | IncMediaPool | Incremental Backup Media Pool
 |  | Veeam Backup to Tape Job | DisplayName |
 |  |  | PrincipalName |
 |  |  | InstanceUid |
 |  |  | Type |
 |  |  | BackupServer |
 |  |  | Schedule |
 |  |  | ScheduleEnabled |
 |  |  | FullMediaPool | Full Backup Media Pool
 |  |  | IncMediaPool | Incremental Backup Media Pool
 |  | Veeam SureBackup Job | DisplayName |
 |  |  | PrincipalName |
 |  |  | InstanceUid |
 |  |  | Type |
 |  |  | BackupServer |
 |  |  | Schedule |
 |  |  | ScheduleEnabled |
 |  |  | AppGroup | Application group
 |  |  | LinkedJobs | Linked Jobs
Veeam Backup Repository Discovery | Veeam.Backup.BackupRepository.Discovery | Veeam Backup Repository | DisplayName |
 |  |  | PrincipalName |
 |  |  | InstanceUid | InstanceUid
 |  |  | MaxConcurrentJobs | Max Concurrent Jobs
 |  |  | Capacity | Capacity GB
 |  |  | RepositoryPath | Path
 |  |  | vPowerNFS | vPower Enabled
 |  |  | Type | Type
 |  |  | Version | Version
 |  |  | Host | Host
 |  | Veeam Backup Repositories | DisplayName |
 |  |  | PrincipalName |
 |  |  | BackupServer | Backup Server
Veeam Backup Server Properties Discovery | Veeam.Backup.BackupServerProperties.Discovery |


Rules and Monitors

This section described MP for Veeam Backup & Replication rules and monitors.

Performance Collection Rules

Event-Based Rules

Event Monitors

Dependency Monitors

Script Monitors


Performance Collection Rules

Target | Rule/Alert Name | Object Name | Counter Name | Data Warehouse | Enabled | Overrides
Veeam Backup Abstract Job | Veeam Job Backup Size GB | Veeam Job | Backup Size GB | yes | yes | no
Veeam Backup Abstract Job | Veeam Job Compression Ratio % | Veeam Job | Compression Ratio % | yes | yes | no
Veeam Backup Abstract Job | Veeam Job Deduplication Ratio % | Veeam Job | Deduplication Ratio % | yes | yes | no
Veeam Backup Abstract Job | Veeam Job Duration | Veeam Job | Duration Min | yes | yes | no
Veeam Backup Abstract Job | Veeam Job Processed Size GB | Veeam Job | Processed GB | yes | yes | no
Veeam Backup Abstract Job | Veeam Job Processing Rate MBps | Veeam Job | Processing Rate MBps | yes | yes | no
Veeam Backup Abstract Job | Veeam Job Transferred Size GB | Veeam Job | Transferred GB | yes | yes | no
Veeam Backup Proxy | Veeam Backup Proxy Concurrent Tasks | $Data/Property[@Name='ObjectName']$ | Concurrent Tasks | yes | yes | no
Veeam Backup Proxy Service | Veeam Backup Proxy CPU Used % | $Data/Property[@Name='ObjectName']$ | CPU Used % | yes | yes | no
Veeam Backup Proxy Service | Veeam Backup Proxy Memory Used % | $Data/Property[@Name='ObjectName']$ | Memory Used % | yes | yes | no
Veeam Backup Proxy Service | Veeam Backup Proxy Memory Used MB | $Data/Property[@Name='ObjectName']$ | Memory Used MB | yes | yes | no
Veeam Backup Repository | Veeam Backup Repository FreeSpace GB | Veeam Backup Repository | Free Space GB | yes | yes | no
Veeam Backup Repository | Veeam Backup Repository FreeSpace Pct | Veeam Backup Repository | Free Space % | yes | yes | no
Veeam Backup Repository | Veeam Backup Repository Stored VMs | Veeam Backup Repository | Stored VMs | yes | yes | no


Event-Based Rules

Target | Rule/Alert Name | Enabled | Overrides
Veeam Backup Server | Veeam Backup MP Rule - Backup Job Session Started | yes | no
Veeam Backup Server | Veeam Backup MP Rule - Restore Point Created | yes | no
Veeam Backup Server | Veeam Backup MP Rule - Restore Point Removed | yes | no
Veeam Backup Server | Veeam Backup MP Rule - Restore Point Updated | yes | no
Veeam Backup Server | Veeam Backup MP Rule - SureBackup Job Session Started | yes | no


Event Monitors

Target | Monitor/Alert Name | Error event ID | Close Event ID | Enabled | Overrides
Veeam Backup Catalog Data Service | Veeam Backup: Catalog Data Service Status | Service NotRunning | Service Running | yes | no
Veeam Backup Enterprise Manager | Veeam Backup: Enterprise Manager Service Status | Service NotRunning | Service Running | yes | no
Veeam Backup Hyper-V Integration Service | Veeam Backup: Hyper-V Integration Service Status | Service NotRunning | Service Running | yes | no
Veeam Backup Proxy Service | Veeam Backup: Proxy Service Status | Service NotRunning | Service Running | yes | no
Veeam Backup Server | Veeam Backup: Backup Service Status | Service NotRunning | Service Running | yes | no
Veeam Installer Service | Veeam Backup: Installer Service Status | Service NotRunning | Service Running | yes | no
Veeam vPower NFS Service | Veeam Backup: Veeam vPower NFS Service Status | Service NotRunning | Service Running | yes | no
Veeam WAN Accelerator Service | Veeam Backup: WAN Accelerator Service Status | Service NotRunning | Service Running | yes | no


Dependency Monitors

Target | Monitor/Alert Name | Category | Parent Monitor | Member Monitor | Enabled | Overrides
Veeam Backup Jobs | Backup Job Availability State Rollup | Availability | Availability | Availability | yes | no
Veeam Backup Proxies | Backup Proxy Availability State Rollup | Availability | Availability | Availability | yes | no
Veeam Backup Repositories | Backup Repository Availability State Rollup | Availability | Availability | Availability | yes | no
Veeam Backup Server | Backup Proxy Container Availability State Rollup | Availability | Availability | Availability | yes | no
Veeam Backup Server | Backup Repository Container Availability State Rollup | Availability | Availability | Availability | yes | no
Veeam Backup Server | Backup WAN Accelerator Container Availability State Rollup | Availability | Availability | Availability | yes | no
Veeam WAN Accelerators | Backup WAN Accelerator Availability State Rollup | Availability | Availability | Availability | yes | no


Script Monitors

Target | Monitor/Alert Name | Enabled | Script Name | Overrides
Veeam Backup Server | Veeam Backup: License Alert | yes | LicenseMonitor.js | no
Veeam Backup Repository | Veeam Backup: Repository Free Disk Space Analysis | yes | RepositoryFreeSpaceThreshold.js | no
Veeam WAN Accelerator | Veeam Backup: WAN Accelerator Connection Status | yes | WANAcceleratorAvailability.js | no
Veeam Backup Proxy | Veeam Backup: Proxy Connection Status | yes | ProxyAvailability.js | no
Veeam Backup Repository | Veeam Backup: Repository Connection Status | yes | RepositoryAvailability.js | no


MP for Veeam Backup and Replication Metric Definitions

MP for Veeam Backup & Replication Metric Definitions

This section describes performance metrics collected from Veeam Backup & Replication systems.

Veeam Job

Veeam Backup Proxy

Veeam Backup Proxy Service

Veeam Backup Repository

Veeam WAN Accelerator


Veeam Job

Object | Counter | Instance | Definition
Veeam Job | Duration Min | _Total | Duration of the competed job in minutes.
Veeam Job | Processing Rate MBps | _Total | Processing speed in MBps for the completed job.
Veeam Job | Processed Size GB | _Total | Amount of data the backup job processed in GB.
Veeam Job | Transferred GB | _Total | Amount of data the backup job actually transferred to a backup repository.
Veeam Job | Backup Size GB | _Total | Amount of data the backup job need to process in GB.
Veeam Job | Compression Ratio % | _Total | Compression ratio in percentage, estimated as amount of data have to be transferred compared to backup size.
Veeam Job | Deduplication Ratio % | _Total | Deduplication ratio in percentage, estimated as data have to be transferred compared to data actually transferred.


Veeam Backup Proxy

Object | Counter | Instance | Definition
Veeam Backup Proxy | Concurrent Tasks | _Total | Number of currently running backup tasks.
Veeam Backup Proxy | Transferred GB | _Total | Amount of data transferred by a backup proxy per hour.
Veeam Backup Proxy | Processed VMs | _Total | Number of VMs processed by a backup proxy per hour.


Veeam Backup Proxy Service

Object | Counter | Instance | Definition
Veeam Backup Proxy | CPU Used % | Per-VeeamAgent.exe process, Total for VeeamAgent.exe | Amount of CPU resources utilized by all processes (_Total instance) and VeeamAgent.exe process, as a percentage of available CPU resources.
Veeam Backup Proxy | Memory Used % | Per-VeeamAgent.exe process, Total for VeeamAgent.exe | Amount of memory resources utilized by all processes (_Total instance) and VeeamAgent.exe process, as a percentage of available Memory resources.
Veeam Backup Proxy | Memory Used MB | Per-VeeamAgent.exe process, Total for VeeamAgent.exe | Amount of memory consumed by all backup proxy services.


Veeam Backup Repository

Object | Counter | Instance | Definition
Veeam Backup Repository | Concurrent Tasks | _Total | Number of currently running backup tasks.
Veeam Backup Repository | Transferred GB | _Total | Amount of data transferred to a backup repository per hour.
Veeam Backup Repository | Stored VMs | _Total | Number of VMs with backup points stored on the backup repository.
Veeam Backup Repository | Free Space GB | _Total | Amount of free disk space on the backup repository in GB.
Veeam Backup Repository | Free Space% | _Total | Amount of free disk space on the backup repository in percentage to the overall Repository capacity.


Veeam WAN Accelerator

 Top Previous
Object | Counter | Instance | Definition
Veeam WAN Accelerator | Network Load % | _Total | Network load for a job is calculated as percent of time this job spent waiting for network to respond compared to overall time job spent waiting for all operations to complete.
Veeam WAN Accelerator | Transferred GB | _Total | Amount of data transferred by a WAN accelerator per hour.
Veeam WAN Accelerator | Traffic Savings GB | _Total | Difference between data which has been processed and selected for the transfer, and data actually transferred by WAN accelerator after applying global deduplication algorithms.
Veeam WAN Accelerator | Transferred Restore Points | _Total | Amount of restore points transferred by a WAN accelerator per hour.
Veeam WAN Accelerator | Cache Used Space GB | _Total | Amount of data stored in the WAN accelerator deduplication cache.